POJ 2168 Joke with Turtles
Joke with Turtles
Time Limit: 1000MS
Memory Limit: 65536K
Total Submissions: 1203
Accepted: 319
Special Judge
Description
There is a famous joke-riddle for children:
Three turtles are crawling along a road. One turtle says: "There are two turtles ahead of me."
The other turtle says: "There are two turtles behind me."The third turtle says: "There are
two turtles ahead of me and two turtles behind me."How could this have happened?
The answer is -- the third turtle is lying!
Now in this problem you have n turtles crawling along a road. Some of them are crawling in a group, so that they do not see members of their group neither ahead nor behind them. Each turtle makes a statement of the form: "There are ai turtles crawling ahead of me and bi turtles crawling behind me."Your task is to find the minimal number of turtles that must be lying.
Let us formalize this task. Turtle i has xi coordinate. Some turtles may have the same coordinate. Turtle i tells the truth if and only if ai is the number of turtles such that xj > xi and bi is the number of turtles such that xj < xi. Otherwise, turtle i is lying.
Input
The first line of the input contains integer number n (1 <= n <= 1000). It is followed by n lines containing numbers ai and bi (0 <= ai, bi <= 1000) that describe statements of each turtle for i from 1 to n.
Output
On the first line of the output file write an integer number m -- the minimal number of turtles that must be lying, followed by m integers -- turtles that are lying. Turtles can be printed in any order. If there are different sets of m lying turtles, then print any of them.
Sample Input
5
0 2
0 3
2 1
1 2
4 0
Sample Output
2 1 4
Source
Northeastern Europe 2004
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn=1100;
int n,cnt[maxn][maxn],dp[maxn],s[maxn][3],pre[maxn],ans[maxn][2];
void init()
{
memset(cnt,0,sizeof(cnt));
memset(dp,-1,sizeof(dp));
}
int DP(int x)
{
if(dp[x]!=-1) return dp[x];
if(x==0) return dp[x]=0;
int ret=0;
for(int i=1;i<=x;i++)
{
if(ret<=DP(x-i)+min(cnt[x-i][n-x],i))
{
ret=dp[x-i]+min(cnt[x-i][n-x],i);
pre[x]=x-i;
ans[x][0]=x-i;ans[x][1]=n-x;
}
}
return dp[x]=ret;
}
int main()
{
while(scanf("%d",&n)!=EOF)
{
init();
for(int i=0;i<n;i++)
{
scanf("%d%d",&s[i][0],&s[i][1]);
cnt[s[i][0]][s[i][1]]++;
}
int res=DP(n);
for(int i=n;i;i=pre[i])
{
for(int j=0,k=i-pre[i];k&&j<n;j++)
{
if(s[j][0]==ans[i][0]&&s[j][1]==ans[i][1])
{
k--;
s[j][2]=1;
}
}
}
printf("%d",n-res);
for(int i=0;i<n;i++) if(!s[i][2]) printf(" %d",i+1);
putchar(10);
}
return 0;
}
이 내용에 흥미가 있습니까?
현재 기사가 여러분의 문제를 해결하지 못하는 경우 AI 엔진은 머신러닝 분석(스마트 모델이 방금 만들어져 부정확한 경우가 있을 수 있음)을 통해 가장 유사한 기사를 추천합니다:
다양한 언어의 JSONJSON은 Javascript 표기법을 사용하여 데이터 구조를 레이아웃하는 데이터 형식입니다. 그러나 Javascript가 코드에서 이러한 구조를 나타낼 수 있는 유일한 언어는 아닙니다. 저는 일반적으로 '객체'{}...
텍스트를 자유롭게 공유하거나 복사할 수 있습니다.하지만 이 문서의 URL은 참조 URL로 남겨 두십시오.
CC BY-SA 2.5, CC BY-SA 3.0 및 CC BY-SA 4.0에 따라 라이센스가 부여됩니다.