POJ 1154 LETTERS DFS+역 추적
http://poj.org/problem?id=1154
처음으로 역 추적+DFS 사용,학습
LETTERS
Time Limit: 1000MS
Memory Limit: 10000K
Description
A single-player game is played on a rectangular board divided in R rows and C columns. There is a single uppercase letter (A-Z) written in every position in the board.
Before the begging of the game there is a figure in the upper-left corner of the board (first row, first column). In every move, a player can move the figure to the one of the adjacent positions (up, down,left or right). Only constraint is that a figure cannot visit a position marked with the same letter twice.
The goal of the game is to play as many moves as possible.
Write a program that will calculate the maximal number of positions in the board the figure can visit in a single game.
Input
The first line of the input contains two integers R and C, separated by a single blank character, 1 <= R, S <= 20.
The following R lines contain S characters each. Each line represents one row in the board.
Output
The first and only line of the output should contain the maximal number of position in the board the figure can visit.
Sample Input
3 6
HFDFFB
AJHGDH
DGAGEH
Sample Output
6
/* Author : yan
* Question : POJ 1154 LETTERS
* Data && Time : Sunday, January 16 2011 09:04 PM
* Compiler : gcc (Ubuntu 4.4.3-4ubuntu5) 4.4.3
*/
#include<stdio.h>
char map[30][30];
int row,col;
int visited[26];
int max=-1;
/*
* , .
* , ,
* , —— "
* ", , .
*/
void DFS(int a,int b,int cnt)// ,
{
if(visited[map[a][b]-'A']) return;
//printf("visited %d %d %c/n",a,b,map[a][b]);
if(max<cnt) max=cnt;
if(b>0)
{
visited[map[a][b]-'A']=1;
DFS(a,b-1,cnt+1);
visited[map[a][b]-'A']=0;
}
if(b<col-1)
{
visited[map[a][b]-'A']=1;
DFS(a,b+1,cnt+1);
visited[map[a][b]-'A']=0;
}
if(a>0)
{
visited[map[a][b]-'A']=1;
DFS(a-1,b,cnt+1);
visited[map[a][b]-'A']=0;
}
if(a<row-1)
{
visited[map[a][b]-'A']=1;
DFS(a+1,b,cnt+1);
visited[map[a][b]-'A']=0;
}
}
int main()
{
freopen("input","r",stdin);
int i;
scanf("%d %d",&row,&col);
for(i=0;i<row;i++) scanf("%s",map[i]);
DFS(0,0,1);
printf("%d",max);
return 0;
}
이 내용에 흥미가 있습니까?
현재 기사가 여러분의 문제를 해결하지 못하는 경우 AI 엔진은 머신러닝 분석(스마트 모델이 방금 만들어져 부정확한 경우가 있을 수 있음)을 통해 가장 유사한 기사를 추천합니다:
Ubuntu 22.04에 캐디 설치 - HostnExtra이 기사에서는 Ubuntu 22.04에 Caddy를 설치하는 방법을 설명합니다. 이 문서는 설치 프로세스를 안내하고 웹 사이트를 호스팅합니다. Caddy 웹 서버는 Go로 작성된 오픈 소스 웹 서버입니다. Ubunt...
텍스트를 자유롭게 공유하거나 복사할 수 있습니다.하지만 이 문서의 URL은 참조 URL로 남겨 두십시오.
CC BY-SA 2.5, CC BY-SA 3.0 및 CC BY-SA 4.0에 따라 라이센스가 부여됩니다.