POJ 1154 LETTERS DFS+역 추적


http://poj.org/problem?id=1154
처음으로 역 추적+DFS 사용,학습
LETTERS
Time Limit: 1000MS
 
Memory Limit: 10000K
Description
A single-player game is played on a rectangular board divided in R rows and C columns. There is a single uppercase letter (A-Z) written in every position in the board. 
Before the begging of the game there is a figure in the upper-left corner of the board (first row, first column). In every move, a player can move the figure to the one of the adjacent positions (up, down,left or right). Only constraint is that a figure cannot visit a position marked with the same letter twice. 
The goal of the game is to play as many moves as possible. 
Write a program that will calculate the maximal number of positions in the board the figure can visit in a single game.
Input
The first line of the input contains two integers R and C, separated by a single blank character, 1 <= R, S <= 20. 
The following R lines contain S characters each. Each line represents one row in the board.
Output
The first and only line of the output should contain the maximal number of position in the board the figure can visit.
Sample Input
3 6
HFDFFB
AJHGDH
DGAGEH

Sample Output
6
/* Author : yan
 * Question : POJ 1154 LETTERS
 * Data && Time : Sunday, January 16 2011 09:04 PM
 * Compiler : gcc (Ubuntu 4.4.3-4ubuntu5) 4.4.3
*/
#include<stdio.h>
char map[30][30];
int row,col;
int visited[26];
int max=-1;
/*
*      ,                   .
*   ,                 ,       
*      ,              ——  "    
*   ",        ,                .
*/
void DFS(int a,int b,int cnt)//   ,
{
	if(visited[map[a][b]-'A']) return;
	//printf("visited %d %d  %c/n",a,b,map[a][b]);
	if(max<cnt) max=cnt;
	if(b>0)
	{
		visited[map[a][b]-'A']=1;
		DFS(a,b-1,cnt+1);
		visited[map[a][b]-'A']=0;
	}
	if(b<col-1)
	{
		visited[map[a][b]-'A']=1;
		DFS(a,b+1,cnt+1);
		visited[map[a][b]-'A']=0;
	}
	if(a>0)
	{
		visited[map[a][b]-'A']=1;
		DFS(a-1,b,cnt+1);
		visited[map[a][b]-'A']=0;
	}
	if(a<row-1)
	{
		visited[map[a][b]-'A']=1;
		DFS(a+1,b,cnt+1);
		visited[map[a][b]-'A']=0;
	}

}
int main()
{
	freopen("input","r",stdin);
	int i;

	scanf("%d %d",&row,&col);
	for(i=0;i<row;i++) scanf("%s",map[i]);
	DFS(0,0,1);
	printf("%d",max);
	return 0;
}
 

좋은 웹페이지 즐겨찾기