poj1056
3413 단어 poj
IMMEDIATE DECODABILITY
Time Limit: 1000MS
Memory Limit: 10000K
Total Submissions: 7371
Accepted: 3513
Description
An encoding of a set of symbols is said to be immediately decodable if no code for one symbol is the prefix of a code for another symbol. We will assume for this problem that all codes are in binary, that no two codes within a set of codes are the same, that each code has at least one bit and no more than ten bits, and that each set has at least two codes and no more than eight.
Examples: Assume an alphabet that has symbols {A, B, C, D}
The following code is immediately decodable:
A:01 B:10 C:0010 D:0000
but this one is not:
A:01 B:10 C:010 D:0000 (Note that A is a prefix of C)
Input
Write a program that accepts as input a series of groups of records from standard input. Each record in a group contains a collection of zeroes and ones representing a binary code for a different symbol. Each group is followed by a single separator record containing a single 9; the separator records are not part of the group. Each group is independent of other groups; the codes in one group are not related to codes in any other group (that is, each group is to be processed independently).
Output
For each group, your program should determine whether the codes in that group are immediately decodable, and should print a single output line giving the group number and stating whether the group is, or is not, immediately decodable.
Sample Input
01
10
0010
0000
9
01
10
010
0000
9
Sample Output Set 1 is immediately decodable
Set 2 is not immediately decodable
Source Pacific Northwest 1998
물 건너다
#include <iostream>
using namespace std;
char code[9][11];
bool checkPrefix(const char *src, const char *dst)
{
int i=0;
bool flag=true;
while(src[i]!='\0')
{
if(src[i]!=dst[i])
flag=false;
i++;
}
return flag;
}
int main()
{
int i,cas=1;
bool isPrefix, isCode;
while(cin>>code[0])
{
i=1;
isCode=true;
while(cin>>code[i] && code[i][0]!='9')
i++;
for(int j=0; j<i; j++)
{
for(int k=0; k<i; k++)
{
if(k==j)
continue;
if(checkPrefix(code[j],code[k]))
{
isCode=false;
break;
}
}
}
if(isCode)
cout<<"Set "<<cas<<" is immediately decodable"<<endl;
else
cout<<"Set "<<cas<<" is not immediately decodable"<<endl;
cas++;
}
return 0;
}
이 내용에 흥미가 있습니까?
현재 기사가 여러분의 문제를 해결하지 못하는 경우 AI 엔진은 머신러닝 분석(스마트 모델이 방금 만들어져 부정확한 경우가 있을 수 있음)을 통해 가장 유사한 기사를 추천합니다:
POJ3071: Football(확률 DP)Consider a single-elimination football tournament involving 2n teams, denoted 1, 2, …, 2n. After n rounds, only one team...
텍스트를 자유롭게 공유하거나 복사할 수 있습니다.하지만 이 문서의 URL은 참조 URL로 남겨 두십시오.
CC BY-SA 2.5, CC BY-SA 3.0 및 CC BY-SA 4.0에 따라 라이센스가 부여됩니다.