【PAT】1009. Product of Polynomials (25)
분석: 간단 한 문제.상승 시 지 수 를 더 하면 계수 가 상승 하면 되 고 수출 시 지수 가 높 은 것 에서 낮은 것 으로 나 타 났 다.주의 점: 다항식 상승 후 지 수 는 최고 2000 에 달 할 수 있다.
제목 설명:
This time, you are supposed to find A*B where A and B are two polynomials.
Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < ... < N2 < N1 <=1000.
Output Specification:
For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.
Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 3 3.6 2 6.0 1 1.6
참조 코드:
#include<iostream>
#include<iomanip>
#include<string.h>
using namespace std;
#define max 1000
double input1[max + 1];
double input2[max + 1];
double result[2*max + 1];
int main()
{
memset(input1,0,sizeof(input1));
memset(input2,0,sizeof(input2));
memset(result,0,sizeof(result));
int k;
int i,j;
int e;
//int temp=0; //
double c;
int count = 0; // 。
cin>>k;
for(i=0; i<k; i++)
{
cin>>e>>c;
input1[e] += c;
}
cin>>k;
for(i=0; i<k; i++)
{
cin>>e>>c;
input2[e] += c;
}
for(i=0; i<=1000; i++)
{
for(j=0; j<=1000; j++)
{
result[i+j] += input1[i]*input2[j];
}
}
for(i=0; i<=2000; i++) if(result[i] != 0) count++;
cout<<count;
for(i=2000; i >= 0; i--)
{
if(result[i] != 0.0) {
cout<<" "<<i;
cout<<fixed<<setprecision(1);
cout<<" "<<result[i];
}
}
cout<<endl;
return 0;
}
이 내용에 흥미가 있습니까?
현재 기사가 여러분의 문제를 해결하지 못하는 경우 AI 엔진은 머신러닝 분석(스마트 모델이 방금 만들어져 부정확한 경우가 있을 수 있음)을 통해 가장 유사한 기사를 추천합니다:
PAT 01-2텍스트를 자유롭게 공유하거나 복사할 수 있습니다.하지만 이 문서의 URL은 참조 URL로 남겨 두십시오.
CC BY-SA 2.5, CC BY-SA 3.0 및 CC BY-SA 4.0에 따라 라이센스가 부여됩니다.