PAT (Advanced Level) Practise 1009 Product of Polynomials (25)
1865 단어 pat
시간 제한
400 ms
메모리 제한
65536 kB
코드 길이 제한
16000 B
판정 절차
Standard
작자
CHEN, Yue
This time, you are supposed to find A*B where A and B are two polynomials.
Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < ... < N2 < N1 <=1000.
Output Specification:
For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.
Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 3 3.6 2 6.0 1 1.6
이전의 그 덧셈과 마찬가지로 0의 문제를 주의해라
#include<cstdio>
#include<stack>
#include<cstring>
#include<string>
#include<algorithm>
#include<iostream>
using namespace std;
const int maxn = 1e5 + 10;
int n, x, cnt;
double a[maxn], b[maxn], c[maxn];
int main()
{
scanf("%d", &n);
while (n--)
{
scanf("%d", &x);
scanf("%lf", &a[x]);
}
scanf("%d", &n);
while (n--)
{
scanf("%d", &x);
scanf("%lf", &b[x]);
}
for (int i = 0; i < 1001; i++)
{
for (int j = 0; j < 1001; j++) c[i + j] += a[i] * b[j];
}
for (int i = 0; i < 2001; i++) if (c[i] != 0) cnt++;
printf("%d", cnt);
for (int i = 2000; i >= 0; i--) if (c[i] != 0) printf(" %d %.1lf", i, c[i]);
return 0;
}
이 내용에 흥미가 있습니까?
현재 기사가 여러분의 문제를 해결하지 못하는 경우 AI 엔진은 머신러닝 분석(스마트 모델이 방금 만들어져 부정확한 경우가 있을 수 있음)을 통해 가장 유사한 기사를 추천합니다:
PAT 01-2텍스트를 자유롭게 공유하거나 복사할 수 있습니다.하지만 이 문서의 URL은 참조 URL로 남겨 두십시오.
CC BY-SA 2.5, CC BY-SA 3.0 및 CC BY-SA 4.0에 따라 라이센스가 부여됩니다.