PAT 1001. A + B Format (20) JAVA 구현
Input
Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.
Output
For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.
Sample Input -1000000 9 Sample Output -999,991
import java.util.Scanner;
public class Main {
public static void main(String[] args) {
int a , b , sum ,count=0;
Scanner in = new Scanner(System.in);
a = in.nextInt();
b = in.nextInt();
StringBuilder sb = new StringBuilder("");
sum = a + b ;
sum = absSum(sum);
while(sum>0){
if(count%3==0 && count>0){
sb.insert(0, ",");
}
int num = sum%10;
sum /= 10 ;
sb.insert(0, num);
count++;
}
if(count == 0){
System.out.print(0);
}
else{
System.out.print(sb.toString());
}
}
public static int absSum(int sum){
if(sum<0){
sum = -sum;
System.out.print("-");
}
return sum;
}
}
이 내용에 흥미가 있습니까?
현재 기사가 여러분의 문제를 해결하지 못하는 경우 AI 엔진은 머신러닝 분석(스마트 모델이 방금 만들어져 부정확한 경우가 있을 수 있음)을 통해 가장 유사한 기사를 추천합니다:
PAT 01-2텍스트를 자유롭게 공유하거나 복사할 수 있습니다.하지만 이 문서의 URL은 참조 URL로 남겨 두십시오.
CC BY-SA 2.5, CC BY-SA 3.0 및 CC BY-SA 4.0에 따라 라이센스가 부여됩니다.