PAT 1001. A + B Format (20) JAVA 구현

3241 단어 patPAT자바
Calculate a + b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).
Input
Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.
Output
For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.
Sample Input -1000000 9 Sample Output -999,991

import java.util.Scanner;


public class Main {

    public static void main(String[] args) {
        int a , b , sum ,count=0;
        Scanner in = new Scanner(System.in);
        a = in.nextInt();
        b = in.nextInt();
        StringBuilder sb = new StringBuilder("");
        sum = a + b ;

        sum = absSum(sum);

        while(sum>0){
            if(count%3==0 && count>0){
                sb.insert(0, ",");
            }
            int num = sum%10;
            sum /= 10 ;
            sb.insert(0, num);
            count++;

        }
        if(count == 0){
            System.out.print(0);
        }
        else{
            System.out.print(sb.toString());
        }


    }

    public static int absSum(int sum){
        if(sum<0){
            sum = -sum;
            System.out.print("-");
        }
        return sum;
    }

}

좋은 웹페이지 즐겨찾기