[Java] 1002. A + B for Polynomials (25) - PAT A 급

2957 단어 PAT
This time, you are supposed to find A+B where A and B are two polynomials.
InputEach input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.
OutputFor each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.
Sample Input2 1 2.4 0 3.22 2 1.5 1 0.5Sample Output3 2 1.5 1 2.9 0 3.2
제목: A + B 를 계산 하 는 합, A 와 B 는 모두 다항식 이다.
PS: github 사용자 @ fs 19910227 이 제공 한 pull request 에 감 사 드 립 니 다 ~
import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;

public class Main {
    static class Polynomial {
        private static int MAX_SIZE = 1001;
        private double[] coefficients;

        Polynomial(String[] splits) {
            coefficients = new double[MAX_SIZE];
            for (int i = 1; i < splits.length; i += 2) {
                int exp = Integer.valueOf(splits[i]);
                coefficients[exp] = Double.valueOf(splits[i + 1]);
            }
        }

        Polynomial() {
            coefficients = new double[MAX_SIZE];
        }

        public Polynomial add(Polynomial other) {
            Polynomial result = new Polynomial();
            for (int i = 0; i < MAX_SIZE; i++) {
                double v = this.coefficients[i] + other.coefficients[i];
                v = Math.round(v * 10) / 10.0;
                if (v != 0.0) {
                    result.coefficients[i] = v;
                }
            }
            return result;
        }

        @Override
        public String toString() {
            StringBuilder stringBuilder = new StringBuilder();
            int size = 0;
            for (int i = coefficients.length - 1; i >= 0; i--) {
                double v = coefficients[i];
                if (v != 0.0) {
                    stringBuilder.append(i).append(" ").append(v).append(" ");
                    size++;
                }
            }
            stringBuilder.insert(0, size + " ");
            stringBuilder.deleteCharAt(stringBuilder.length() - 1);
            return stringBuilder.toString();
        }
    }

    private static BufferedReader reader = new BufferedReader(new InputStreamReader(System.in));

    public static String[] readLine() throws IOException {
        return reader.readLine().split(" ");
    }

    public static void main(String[] args) throws IOException {
        Polynomial add = new Polynomial(readLine()).add(new Polynomial(readLine()));
        System.out.println(add);
    }
}

좋은 웹페이지 즐겨찾기