라즈파, WN-G300UA, OpenWrt(브리지 모드 편)를 유연하게 융합시켜 보았습니다.
11315 단어 WN-G300UAopenwrtRaspberryPi라우터Router
입문
라우터를 고기능화하는 사용자 정의 펌웨어는 OpenWrt 및 dd-wrt 등이 있지만 가져올 때 첫 번째 난관은 펌웨어를 주입하는 것이다.나 자신은 실패로 인해 많은 고통을 겪었다.
따라서 우리는 SD카드를 사용하여 쉽게 얻을 수 있는 라즈파와 천선형 와이파이 서브머신을 사용하여 브리지 모드에서 OpenWrt를 사용해 보았다.
주역들
참고 자료
컴퓨터에서 OpenWrt 펌웨어를 다운로드하고 압축을 풀고 SD 카드에 기록합니다.
다음은 Ubuntu 18.04.1의 실행 예입니다.
$ wget https://archive.openwrt.org/releases/18.06.1/targets/brcm2708/bcm2708/openwrt-18.06.1-brcm2708-bcm2708-rpi-ext4-factory.img.gz
$ gzip -d openwrt-18.06.1-brcm2708-bcm2708-rpi-ext4-factory.img.gz
$ sudo dd if=openwrt-18.06.1-brcm2708-bcm2708-rpi-ext4-factory.img of=/dev/sdb bs=1M
루트 파티션을 확장합니다.
OpenWrt를 랩에 작성한 후 루트 파티션을 확장하는 방법
라즈파 암호를 설정합니다.
OpenWrt의 초기 IP 주소는 192.168.1.1입니다.
SD카드를 라즈파에 삽입합니다.LAN 케이블로 라스파와 컴퓨터를 직접 연결하고 전원을 켜세요.컴퓨터 측의 LAN 주소가 DHCP라면 ssh로 콘솔을 연결할 수 있습니다.
루트 비밀번호가 아무것도 설정되지 않아서 좋아하는 걸로 바꿨어요.
$ ssh [email protected]
root@OpenWrt:~# passwd
Changing password for root
New password:
Retype password:
passwd: password for root changed by root
고무 파이의 LAN 포트를 설정합니다.
브리지 모드에서 OpenWrt를 설정합니다.
랩 LAN 포트의 IP 주소를 192.168.3.2로 설정합니다.
전제 조건은 이미 인터넷에 연결된 공유기 192.168.3.1이다.기본 게이트웨이 및 DNS 서버는 192.168.3.1입니다.
root@OpenWrt:~# cp -p /etc/config/network /etc/config/network.org
root@OpenWrt:~# vi /etc/config/network
(변경 전)/etc/config/network
config interface 'lan'
option type 'bridge'
option ifname 'eth0'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'
(변경 후)/etc/config/network
config interface 'lan'
option type 'bridge'
option ifname 'eth0'
option proto 'static'
# option ipaddr '192.168.1.1'
option ipaddr '192.168.3.2'
option netmask '255.255.255.0'
option gateway '192.168.3.1'
option dns '192.168.3.1'
# option ip6assign '60'
설정이 끝난 후 고무 파이의 전원을 한 번 끄세요.root@OpenWrt:~# halt
스카이라인 Wi-Fi 서브머신 WN-G300UA를 설정합니다.
라우터 192.168.3.1과 고무 파이 192.168.3.2는 LAN 케이블을 통해 연결됩니다.
ssh로 실험실에 연결합니다.
$ ssh [email protected]
[email protected]'s password:
WN-G300UA 드라이버를 설치하고 다시 시작합니다.root@OpenWrt:~# opkg update
root@OpenWrt:~# opkg install kmod-rtl8192cu
root@OpenWrt:~# reboot
WN-G300UA의 드라이버를 식별하는지 확인합니다.$ ssh [email protected]
[email protected]'s password:
root@OpenWrt:~# dmesg | grep rtl8192cu
[ 7.513146] rtl8192cu: Chip version 0x11
[ 7.659574] rtl8192cu: Board Type 0
[ 7.675383] rtl8192cu: Loading firmware rtlwifi/rtl8192cufw_TMSC.bin
[ 7.687639] usbcore: registered new interface driver rtl8192cu
Wi-Fi를 설정합니다.
Wi-Fi 활성화, 인증 암호 설정 등.
root@OpenWrt:~# cp -p /etc/config/wireless /etc/config/wireless.org
root@OpenWrt:~# vi /etc/config/wireless
(변경 전)/etc/config/wireless
config wifi-device 'radio0'
option type 'mac80211'
option channel '11'
option hwmode '11g'
option path 'platform/soc/20980000.usb/usb1/1-1/1-1.2/1-1.2:1.0'
option htmode 'HT20'
option disabled '1'
config wifi-iface 'default_radio0'
option device 'radio0'
option network 'lan'
option mode 'ap'
option ssid 'OpenWrt'
option encryption 'none'
(변경 후)/etc/config/wireless
config wifi-device 'radio0'
option type 'mac80211'
option channel '11'
option hwmode '11g'
option path 'platform/soc/20980000.usb/usb1/1-1/1-1.2/1-1.2:1.0'
option htmode 'HT20'
# option disabled '1'
option disabled '0'
config wifi-iface 'default_radio0'
option device 'radio0'
option network 'lan'
option mode 'ap'
option ssid 'OpenWrt'
# option encryption 'none'
option channel 'auto'
option txpower '10'
option country 'JP'
option encryption 'psk-mixed'
option key 'PASSWORD'
다시 시작합니다.root@OpenWrt:~# reboot
wlan0이 나타나는지 확인하십시오.$ ssh [email protected]
[email protected]'s password:
root@OpenWrt:~# ifconfig
br-lan Link encap:Ethernet HWaddr B8:27:EB:3F:33:23
inet addr:192.168.3.2 Bcast:192.168.3.255 Mask:255.255.255.0
inet6 addr: fe80::ba27:ebff:fe3f:3323/64 Scope:Link
inet6 addr: fd4c:e901:b36e::1/60 Scope:Global
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:171 errors:0 dropped:0 overruns:0 frame:0
TX packets:169 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:17093 (16.6 KiB) TX bytes:42675 (41.6 KiB)
eth0 Link encap:Ethernet HWaddr B8:27:EB:3F:33:23
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:177 errors:0 dropped:0 overruns:0 frame:0
TX packets:166 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:17369 (16.9 KiB) TX bytes:44213 (43.1 KiB)
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:32 errors:0 dropped:0 overruns:0 frame:0
TX packets:32 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1
RX bytes:2688 (2.6 KiB) TX bytes:2688 (2.6 KiB)
wlan0 Link encap:Ethernet HWaddr 34:76:C5:8E:D6:67
inet6 addr: fe80::3676:c5ff:fe8e:d667/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:10 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:1230 (1.2 KiB)
DHCP 서버 및 방화벽을 비활성화합니다.
root@OpenWrt:~# /etc/init.d/dnsmasq disable
root@OpenWrt:~# /etc/init.d/dnsmasq stop
root@OpenWrt:~# /etc/init.d/odhcpd disable
root@OpenWrt:~# /etc/init.d/odhcpd stop
root@OpenWrt:~# /etc/init.d/firewall disable
root@OpenWrt:~# /etc/init.d/firewall stop
다시 시작합니다.root@OpenWrt:~# reboot
마지막
이상은 브리지 모드로 최소한의 설정이 끝났습니다.이후 자신의 취향에 따라 조절을 즐기세요.
참고로 제가 추천하는 공유기는 GL-AR150 - GL.iNet 입니다.OpenWrt, dd-wrt 모두 사용할 수 있고 가격도 싸다.
Reference
이 문제에 관하여(라즈파, WN-G300UA, OpenWrt(브리지 모드 편)를 유연하게 융합시켜 보았습니다.), 우리는 이곳에서 더 많은 자료를 발견하고 링크를 클릭하여 보았다 https://qiita.com/somainit/items/9f89f41ef5c10a4dccb8텍스트를 자유롭게 공유하거나 복사할 수 있습니다.하지만 이 문서의 URL은 참조 URL로 남겨 두십시오.
우수한 개발자 콘텐츠 발견에 전념 (Collection and Share based on the CC Protocol.)