도론---spfa+체인식전성:정권회로 존재 여부 판단poj1860:Currency Exchange

6989 단어 Exchange

 


 


Currency Exchange

 


Time Limit: 1000MS
 
Memory Limit: 30000K
Total Submissions: 19881
 
Accepted: 7114

 


Description

 


Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency. 
For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR. 
You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of currencies it exchanges, and real R
AB, C
AB, R
BA and C
BA - exchange rates and commissions when exchanging A to B and B to A respectively. 
Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative sum of money while making his operations. 

 


Input

 


The first line of the input contains four numbers: N - the number of currencies, M - the number of exchange points, S - the number of currency Nick has and V - the quantity of currency units he has. The following M lines contain 6 numbers each - the description of the corresponding exchange point - in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=10
3. 
For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10
-2<=rate<=10
2, 0<=commission<=10
2. 
Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 10
4. 

 


Output

 


If Nick can increase his wealth, output YES, in other case output NO to the output file.

 


Sample Input
3 2 1 20.0
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00

 


Sample Output
YES
 
Source

 


Northeastern Europe 2001 , Northern Subregion

 


 
Mean:
 
너는 약간의 고화폐가 있는데, 지금 너는 이 고화폐로 다른 화폐로 바꾸어야 한다.이 도시에는 N개의 환전소가 있는데 각 환전소는 A----화폐 AB---화폐 BRAB--A를 B로 바꾸는 비례 Cab--A를 B로 바꾸는 수수료 Rba--B를 A로 바꾸는 비례 Cba--B를 A로 바꾸는 수수료를 포함한다. 현재 당신은 번호가 S인 이런 고화폐를 가지고 있다. 당신은 이 고화폐로 일련의 환전을 진행할 것이다. 결국은 고화폐로 환전해야 한다.너는 일련의 환전을 통해 자신의 고화를 늘릴 수 있는지 알고 싶다.N--화폐의 종류 총수(결점수)M--환전점의 수량(변의 갯수)S-당신의 화폐 종류 표지(시점 & 종점)V-당신이 지금 가지고 있는 화폐의 수량
 
 
analyse:
그림에 정권 회로가 존재하는지 판단한다.
spfa를 사용하여 최대 경로를 끊임없이 교체합니다. 만약에 이 과정에서 어떤 점의 교체 횟수가 n회를 초과하면 반드시 정권 회로가 존재합니다.
사실 일반적인 상황에서 각 점의 교체 횟수는 2를 넘지 않기 때문에 이 문제는 n을 3으로 바꾸어도 지나갈 수 있다. 물론 정권회로가 존재하면 반드시 n을 초과하기 때문에 시간이 걸리지 않는 상황에서 n으로 보험점을 판단한다.
 
Time complexity: O(m*k), k는 점당 평균 교체 횟수
 
Source code:
 
//Memory   Time
//  164K     0MS
// by : Snarl_jsb
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<iostream>
#include<vector>
#include<queue>
#include<stack>
#include<iomanip>
#include<string>
#include<climits>
#include<cmath>
#define MAXV 110
#define MAXE 110<<1
#define LL long long
using namespace std;
int n,m,sta;
float num;
int vis[MAXV];
float dis[MAXV];
int cnt[MAXV];
namespace Adj
{
    struct Edge
    {
        int to,next;
        float rate,cost;
    };
    Edge edge[MAXE];
    int top;
    int head[MAXV];
    void init()
    {
        top=1;
        memset(head,0,sizeof(head));
    }
    void addEdge(int u,int v,float rate,float cost)
    {
        edge[top].to=v;
        edge[top].rate=rate;
        edge[top].cost=cost;
        edge[top].next=head[u];
        head[u]=top++;
    }
}
using namespace Adj;

bool spfa()
{
    for(int i=1;i<=n;i++)
        cnt[i]=vis[i]=0,dis[i]=0.0;
    queue<int>Q;
    Q.push(sta);
    vis[sta]=1;
    dis[sta]=num;
    while(!Q.empty())
    {
        int now=Q.front();
        Q.pop();
        vis[now]=0;
        for(int i=head[now];i;i=edge[i].next)
        {
            int son=edge[i].to;
            float tmp=(dis[now]-edge[i].cost)*edge[i].rate*1.0;
            if(dis[son]<tmp)
            {
                dis[son]=tmp;
                if(!vis[son])
                {
                    Q.push(son);
                    vis[son]=1;
                }
                cnt[son]++;
                if(cnt[son]>3)  //    n , 
                    return false;
            }
        }
    }
    return true;
}

int main()
{
//    freopen("cin.txt","r",stdin);
//    freopen("cout.txt","w",stdout);
    scanf("%d %d %d %f",&n,&m,&sta,&num);
    Adj:: init();
    int a,b;
    float r1,c1,r2,c2;
    while(m--)
    {
        scanf("%d %d %f %f %f %f",&a,&b,&r1,&c1,&r2,&c2);
        Adj:: addEdge(a,b,r1,c1);
        Adj:: addEdge(b,a,r2,c2);
    }
    if(!spfa())
        puts("YES");
    else
        puts("NO");
    return 0;
}

 
  

좋은 웹페이지 즐겨찾기