I - An Easy Problem!문제 해결 보고서 (네트워크에서)

I - An Easy Problem!
Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u
Submit 
Status 
Practice 
POJ 1152
Description
Have you heard the fact "The base of every normal number system is 10"? Of course, I am not talking about number systems like Stern Brockot Number System. This problem has nothing to do with this fact but may have some similarity. 
You will be given an N based integer number R and you are given the guaranty that R is divisible by (N-1). You will have to print the smallest possible value for N. The range for N is 2 <= N <= 62 and the digit symbols for 62 based number is (0..9 and A..Z and a..z). Similarly, the digit symbols for 61 based number system is (0..9 and A..Z and a..y) and so on.
Input
Each line in the input will contain an integer (as defined in mathematics) number of any integer base (2..62). You will have to determine what is the smallest possible base of that number for the given conditions. No invalid number will be given as input. The largest size of the input file will be 32KB.
Output
If number with such condition is not possible output the line "such number is impossible!"For each line of input there will be only a single line of output. The output will always be in decimal number system.
Sample Input
3
5
A

Sample Output
4
6
11

제목: 이 수가 2-64진수 중 어느 진수에서 가장 큰지 숫자를 입력하십시오.
알고리즘 사고방식: (출처discuss 토론 구역)
입력한 것은 abcd이고, 그 해가 n진수라고 가정하면
(a*n*n*n + b*n*n + c*n + d)%(n-1)=0
(a*n*n*n)%(n-1)+(b*n*n)%(n-1)+(c*n)%(n-1)+d)%(n-1)=0
(a*(n% (n-1))*(n% (n-1))*(n% (n-1)))+(b* (n% (n-1))*(n% (n-1))))+(c* (n% (n-1)+d)% (n-1)=0
(a*1*1*1+b*1*1+c*1+d)%(n-1)=0
있음: (a+b+c+d)% (n-1) = 0
참고:
If number with such condition is not possible output the line "such number is impossible!"For each line of input there will be only a single line of output. The output will always be in decimal number system.(결과가 없을 수도 있음)
코드:
#include <stdio.h>
#include <string.h>
char a[30005];
int main()
{
 
 int i,len,f,flag;
 __int64 sum;
 while( scanf("%s",a)!=EOF )
 {
  len=strlen(a); 
  sum=0;
  f=1;// , :15  4, 。
  for(i=0;i<len;i++)
  {
   if( a[i]>='0' && a[i]<='9' )
   {
    sum=sum+(a[i]-'0');
    if( a[i]-'0'>f )
     f=a[i]-'0';
   }
   else if( a[i]>='A' && a[i]<='Z' )
   {
    sum=sum+(a[i]-55);
    if( a[i]-55>f )
     f=a[i]-55;
   }
   else
   {
    sum=sum+(a[i]-61);
    if( a[i]-61>f )
     f=a[i]-61;
   }
  }
  flag=1;
  for(i=2;i<=62;i++)
  {
   if( sum%(i-1)==0 && i>f )
   {       
    flag=0;
    printf("%d/n",i);
    break;
   }
  }
  if( flag )
   printf("such number is impossible!/n");
 }
 return 0;
}

좋은 웹페이지 즐겨찾기