hdu-Common Subsequence
3355 단어 sequence
Problem Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X =
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.
Sample Input
abcfbc abfcab programming contest abcd mnp
Sample Output
4 2 0
최 장 공공 서브 시퀀스 문 제 는 최 적 화 된 서브 구조 성 을 가진다.
설정 X = { x1 , ... , xm } Y = { y1 , ... , yn } 그리고 그들의 최 장자 서열 Z = { z1 , ... , zk }
... 하면
만약 xm = yn , ... 하면 zk = xm = yn, 그리고 Z [k - 1] 예. X[m-1] 화해시키다 Y[n-1] 하면, 만약, 만약... xm != yn ,... 뿐만 아니 라 zk != xm , ... 하면 Z 예. X[m-1] 화해시키다 Y 의 최 장 공공 서브 시퀀스 3. xm != yn , ... 뿐만 아니 라 zk != yn , ... 하면 Z 예. Y[n-1] 화해시키다 X 최 장 공통 하위 시퀀스
성질 에서 서브 문 제 를 도 출하 는 재 귀 구조
... 해 야 한다 i = 0 , j = 0 당시 , c[i][j] = 저당 잡히다 i , j > 0 ; xi = yi 당시 , c[i][j] = c[i-1][j-1] + 저당 i , j > 0 ; xi != yi 당시 , c[i][j] = max { c[i][j-1] , c[i-1][j] }
경계 에 주의 하 세 요. 두 꼬치 의 아래 표 지 는 모두 1 에서 시 작 됩 니 다. 재 귀 할 때 0 으로 끝 나 는 표지 이기 때 문 입 니 다 ~
dp[i][j] 네, 맛 없어 요. 길이 가 i 인 문자열 과 길이 가 j 인 문자열 의 최대 공공 하위 문자열 의 길 이 를 표시 합 니 다.
분석:
#include<iostream>
#include<string.h>
using namespace std;
char str1[1005];
char str2[1005];
int dp[1005][1005];
int main()
{
while(scanf("%s %s",str1+1,str2+1)!=EOF)
{
memset(dp,0,sizeof(dp));// ~ dp[0][j:1->len2]=0;
int len1=strlen(str1+1),len2=strlen(str2+1);
for(int i=1;i<=len1;i++)
for(int j=1;j<=len2;j++)
{
if(str1[i]==str2[j])
dp[i][j]=dp[i-1][j-1]+1;
else
dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
}
cout<<dp[len1][len2]<<endl;
}
return 0;
}
다른:
#include<iostream>
#include<cstring>
using namespace std;
int max(int a,int b)
{
return a>b?a:b;
}
int main()
{
int i,j,dp[500][500];
string s1,s2;
while(cin>>s1>>s2)
{
memset(dp,0,sizeof(dp));
for(i=1;i<=s1.size();i++)
{
for(j=1;j<=s2.size();j++)
{
if(s1[i-1]==s2[j-1])dp[i][j]=dp[i-1][j-1]+1;
else dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
}
}
cout<<dp[s1.size()][s2.size()]<<endl;
}
return 0;
}
이 내용에 흥미가 있습니까?
현재 기사가 여러분의 문제를 해결하지 못하는 경우 AI 엔진은 머신러닝 분석(스마트 모델이 방금 만들어져 부정확한 경우가 있을 수 있음)을 통해 가장 유사한 기사를 추천합니다:
POJ 2442 SequenceSequence Time Limit: 6000MS Memory Limit: 65536K Total Submissions: 6120 Accepted: 1897 Description Given m sequences, e...
텍스트를 자유롭게 공유하거나 복사할 수 있습니다.하지만 이 문서의 URL은 참조 URL로 남겨 두십시오.
CC BY-SA 2.5, CC BY-SA 3.0 및 CC BY-SA 4.0에 따라 라이센스가 부여됩니다.