FZU 1543 Avoid The Lakes

Accept: 140    Submit: 206Time Limit: 1000 mSec    Memory Limit : 32768 KB


 Problem Description


Farmer John's farm was flooded in the most recent storm, a fact only aggravated by the information that his cows are deathly afraid of water. His insurance agency will only repay him, however, an amount depending on the size of the largest "lake"on his farm.
The farm is represented as a rectangular grid with N (1<=N<=100) rows and M (1<=M<=100) columns. Each cell in the grid is either dry or submerged, and exactly K (1<=K<=N*M) of the cells are submerged. As one would expect, a lake has a central cell to which other cells connect by sharing a long edge (not a corner). Any cell that shares a long edge with the central cell or shares a long edge with any connected cell becomes a connected cell and is part of the lake.

 Input


The input will consist of several datasets.
Each dataset contains two parts:
  *Line 1: Three space-separated integers: N, M, and K.
  *Lines 2..K+1: Line i+1 describes one submerged location with two space separated integers that are its row and column: R and C.
Input is terminated by end of file.

 Output


For each dataset,you should output the number of cells that the largest lake contains.

 Sample Input


3 4 5 3 2 2 2 3 1 2 3 1 1

 Sample Output



Hint


Input Details:
The farm is a grid with three rows and four columns; five of the cells are submerged. They are located in the positions (row 3, column 2); (row 2, column 2); (row 3, column 1); (row 2, column 3); (row 1, column 1):
 
# . . .
. # # .
# # .. 
// ;  , for n,m , WA 3 .... .....
.#include<iostream>
using namespace std;
int map[101][101];
int Dfs(int i,int j)
{
	int sum=1;
	map[i][j]=0;
	if (map[i-1][j]==1)
		sum+=Dfs(i-1,j);
	if (map[i+1][j]==1)
		sum+=Dfs(i+1,j);
	if (map[i][j-1]==1)
		sum+=Dfs(i,j-1);
	if (map[i][j+1]==1)
		sum+=Dfs(i,j+1);
	return sum;
}
int main()
{
	int n,m,k,i,j,max,t1,t2;
	while(scanf("%d%d%d",&n,&m,&k)!=EOF)
	{
		memset(map,0,sizeof(map));
		for(i=0;i<k;i++)
		{
			scanf("%d%d",&t1,&t2);
			map[t1-1][t2-1]=1;
		}
		max=0;
		for(i=0;i<n;i++)
			for(j=0;j<m;j++)
				if(map[i][j]==1)
				{
					t1=Dfs(i,j);
					if(t1>max) max=t1;
				}
		printf("%d/n",max);
	}
	return 0;
} 

좋은 웹페이지 즐겨찾기