Foreign Exchange(교환 학생 교환)

4520 단어 Exchange

           Foreign Exchange


Your non-profit organization (iCORE - international Confederation of Revolver Enthusiasts) coordinates a very successful foreign student exchange program. Over the last few years, demand has sky-rocketed and now you need assistance with your task. The program your organization runs works as follows: All candidates are asked for their original location and the location they would like to go to. The program works out only if every student has a suitable exchange partner. In other words, if a student wants to go from A to B, there must be another student who wants to go from B to A. This was an easy task when there were only about 50 candidates, however now there are up to 500000 candidates!
Input
The input file contains multiple cases. Each test case will consist of a line containing n – the number of candidates (1 ≤ n ≤ 500000), followed by n lines representing the exchange information for each candidate. Each of these lines will contain 2 integers, separated by a single space, representing the candidate’s original location and the candidate’s target location respectively. Locations will be represented by nonnegative integer numbers. You may assume that no candidate will have his or her original location being the same as his or her target location as this would fall into the domestic exchange program. The input is terminated by a case where n = 0; this case should not be processed.
Output
For each test case, print ‘YES’ on a single line if there is a way for the exchange program to work out, otherwise print ‘NO’.
Sample Input

1 2
2 1
3 4
4 3
100 200
200 100
57 2
2 57
1 2
2 1

1 2
3 4
5 6
7 8
9 10
11 12
13 14
15 16
17 18
19 20
0
Sample Output
YES
NO
 
문제: 두 개의 수조 s[i], t[i]를 열고 수조 데이터를 작은 것에서 큰 순서로 정렬합니다. 순환이 일일이 대응하면 YES를 교환하고 출력할 수 있습니다. 그렇지 않으면 하나만 같지 않으면 NO를 출력할 수 있습니다.
 
#include<iostream>
#include<algorithm>
using namespace std;
int s[500000],t[500000];
// 
int main()
{
  int n,i;
  while(cin>>n&&n)
{
  for(i=0; i<n; i++)
    cin>>s[i]>>t[i];
  sort(s,s+n);// 
  sort(t,t+n);
  int f=0;
  for(i=0; i<n; i++)
{
    if(s[i]!=t[i])
  {
      f=1;
      break;
  }
}

if(f)
    cout<<"NO"<<endl;
else
    cout<<"YES"<<endl;
}
return 0;

}

 

좋은 웹페이지 즐겨찾기