RasPie, WN-G300UA 및 OpenWrt(라우터 모드 편)를 유연하게 통합해 보십시오.

입문


공유기를 고기능화시키는 사용자 정의 펌웨어는 OpenWrt와 dd-wrt 등을 포함하지만, 배치할 때의 첫 번째 난제는 펌웨어를 주입하는 것이다.나 자신은 실패로 인해 많은 고통을 겪었다.
따라서 우리는 SD카드를 사용하여 쉽게 얻을 수 있는 라즈파와 천선형 와이파이 서브머신을 사용하여 공유기 모드에서 OpenWrt를 사용해 보았다.
브리지 모드는 여기를 참고하세요.
라즈파, WN-G300UA, OpenWrt(브리지 모드 편)를 유연하게 융합시켜 보았습니다.

주역들

  • Raspberry Pi 1 Model B+
  • I-O DATA Wi-Fi 무선 LAN 서브머신 11n/g/b300Mbps 스카이라인 WN-G300UA
  • OpenWrt Project: OpenWrt v18.06.1

  • 참고 자료

  • OpenWrt - Routed AP
  • GitHubGist - vbajpai/gist:55091f8a066717bce9c4
  • 컴퓨터에서 OpenWrt 펌웨어를 다운로드하고 압축을 풀고 SD 카드에 기록합니다.


    다음은 Ubuntu 18.04.1의 실행 예입니다.
    $ wget https://archive.openwrt.org/releases/18.06.1/targets/brcm2708/bcm2708/openwrt-18.06.1-brcm2708-bcm2708-rpi-ext4-factory.img.gz
    $ gzip -d openwrt-18.06.1-brcm2708-bcm2708-rpi-ext4-factory.img.gz
    $ sudo dd if=openwrt-18.06.1-brcm2708-bcm2708-rpi-ext4-factory.img of=/dev/sdb bs=1M
    

    루트 파티션을 확장합니다.


    OpenWrt를 랩에 작성한 후 루트 파티션을 확장하는 방법

    라즈파 암호를 설정합니다.


    OpenWrt의 초기 IP 주소는 192.168.1.1입니다.
    SD카드를 라즈파에 삽입합니다.LAN 케이블로 라스파와 컴퓨터를 직접 연결하고 전원을 켜세요.컴퓨터 측의 LAN 주소가 DHCP라면 ssh로 콘솔을 연결할 수 있습니다.
    루트 비밀번호가 아무것도 설정되지 않아서 좋아하는 걸로 바꿨어요.
    $ ssh [email protected]
    
    root@OpenWrt:~# passwd
    Changing password for root
    New password: 
    Retype password: 
    passwd: password for root changed by root
    

    고무 파이의 LAN 포트를 설정합니다.


    라우터 모드에서 OpenWrt를 설정합니다.
    라스파 LAN 포트의 IP 주소를 192.168.3.2로 설정하고 Wi-Fi의 IP 주소를 192.168.2.1로 설정합니다.
    Wi-Fi의 네트워크 주소는 192.168.2.0입니다.
    전제 조건은 이미 인터넷에 연결된 공유기 192.168.3.1이다.
    기본 게이트웨이 및 DNS 서버는 192.168.3.1입니다.
    root@OpenWrt:~# cp -p /etc/config/network /etc/config/network.org
    root@OpenWrt:~# vi /etc/config/network
    
    (변경 전)
    /etc/config/network
    config interface 'lan'
            option type 'bridge'
            option ifname 'eth0'
            option proto 'static'
            option ipaddr '192.168.1.1'
            option netmask '255.255.255.0'
            option ip6assign '60'
    
    (변경 후)
    /etc/config/network
    config interface 'lan'
            option type 'bridge'
            option ifname 'eth0'
            option proto 'static'
    #       option ipaddr '192.168.1.1'
            option ipaddr '192.168.3.2'   
            option netmask '255.255.255.0'
            option gateway '192.168.3.1'
            option dns '192.168.3.1'
    #        option ip6assign '60'
    
    config interface 'wifi'
            option proto 'static'
            option ipaddr '192.168.2.1'
            option netmask '255.255.255.0' 
    
    설정이 끝난 후 고무 파이의 전원을 한 번 끄세요.
    root@OpenWrt:~# halt
    

    스카이라인 Wi-Fi 서브머신 WN-G300UA를 설정합니다.


    라우터 192.168.3.1과 고무 파이 192.168.3.2는 LAN 케이블을 통해 연결됩니다.
    ssh로 실험실에 연결합니다.
    $ ssh [email protected]
    [email protected]'s password:
    
    WN-G300UA 드라이버를 설치하고 다시 시작합니다.
    root@OpenWrt:~# opkg update
    root@OpenWrt:~# opkg install kmod-rtl8192cu
    root@OpenWrt:~# reboot
    
    WN-G300UA의 드라이버를 식별하는지 확인합니다.
    $ ssh [email protected]
    [email protected]'s password:
    
    root@OpenWrt:~# dmesg | grep rtl8192cu
    [    7.513146] rtl8192cu: Chip version 0x11
    [    7.659574] rtl8192cu: Board Type 0
    [    7.675383] rtl8192cu: Loading firmware rtlwifi/rtl8192cufw_TMSC.bin
    [    7.687639] usbcore: registered new interface driver rtl8192cu
    

    Wi-Fi를 설정합니다.


    Wi-Fi 활성화, 인증 암호 설정 등.
    root@OpenWrt:~# cp -p /etc/config/wireless /etc/config/wireless.org
    root@OpenWrt:~# vi /etc/config/wireless
    
    (변경 전)
    /etc/config/wireless
    config wifi-device 'radio0'
            option type 'mac80211'
            option channel '11'
            option hwmode '11g'
            option path 'platform/soc/20980000.usb/usb1/1-1/1-1.2/1-1.2:1.0'
            option htmode 'HT20'
            option disabled '1'
    
    config wifi-iface 'default_radio0'
            option device 'radio0'
            option network 'lan'
            option mode 'ap'
            option ssid 'OpenWrt'
            option encryption 'none'
    
    (변경 후)
    /etc/config/wireless
    config wifi-device 'radio0'
            option type 'mac80211'
            option channel '11'
            option hwmode '11g'
            option path 'platform/soc/20980000.usb/usb1/1-1/1-1.2/1-1.2:1.0'
            option htmode 'HT20'
    #        option disabled '1'
            option disabled '0'
    
    config wifi-iface 'default_radio0'
            option device 'radio0'
    #       option network 'lan'
            option network 'wifi'
            option mode 'ap'     
            option ssid 'OpenWrt'   
    #       option encryption 'none'
            option channel 'auto'
            option txpower '10'
            option country 'JP'          
            option encryption 'psk-mixed'
            option key 'PASSWORD'
    
    다시 시작합니다.
    root@OpenWrt:~# reboot
    
    wlan0이 나타나는지 확인하십시오.
    $ ssh [email protected]
    [email protected]'s password:
    
    root@OpenWrt:~# ifconfig
    br-lan    Link encap:Ethernet  HWaddr B8:27:EB:3F:33:23  
              inet addr:192.168.3.2  Bcast:192.168.3.255  Mask:255.255.255.0
              inet6 addr: fe80::ba27:ebff:fe3f:3323/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:69 errors:0 dropped:0 overruns:0 frame:0
              TX packets:70 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:8149 (7.9 KiB)  TX bytes:9688 (9.4 KiB)
    
    eth0      Link encap:Ethernet  HWaddr B8:27:EB:3F:33:23  
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:78 errors:0 dropped:0 overruns:0 frame:0
              TX packets:70 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:8563 (8.3 KiB)  TX bytes:10424 (10.1 KiB)
    
    lo        Link encap:Local Loopback  
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:65536  Metric:1
              RX packets:16 errors:0 dropped:0 overruns:0 frame:0
              TX packets:16 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1 
              RX bytes:1408 (1.3 KiB)  TX bytes:1408 (1.3 KiB)
    
    wlan0     Link encap:Ethernet  HWaddr 34:76:C5:8E:D6:67  
              inet addr:192.168.2.1  Bcast:192.168.2.255  Mask:255.255.255.0
              inet6 addr: fe80::3676:c5ff:fe8e:d667/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:7 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:0 (0.0 B)  TX bytes:864 (864.0 B)
    

    DHCP 서버를 설정합니다.

    root@OpenWrt:~# cp -p /etc/config/dhcp /etc/config/dhcp.org
    root@OpenWrt:~# vi /etc/config/dhcp
    
    (추가)
    /etc/config/dhcp
    config dhcp 'wifi'                               
            option interface 'wifi'                  
            option start '100'       
            option limit '150'       
            option leasetime '12h'
    

    방화벽을 설치하다.

    root@OpenWrt:~# cp -p /etc/config/firewall /etc/config/firewall.org
    root@OpenWrt:~# vi /etc/config/firewall
    
    (변경 전)
    /etc/config/firewall
    config zone
            option name             lan
            list   network          'lan'
            option input            ACCEPT
            option output           ACCEPT
            option forward          ACCEPT
    
    (변경 후)
    /etc/config/firewall
    config zone
            option name             lan
            list   network          'lan'
            option input            ACCEPT
            option output           ACCEPT
            option forward          ACCEPT
            option network          'lan wifi'
            option masq             1 
    
    (추가)
    /etc/config/firewall
    config zone
            option name       wifi
            list   network    'wifi'
            option input      ACCEPT
            option output     ACCEPT
            option forward    REJECT
    
    config forwarding                               
            option src        wifi                  
            option dest       lan                   
    
    config forwarding                               
            option src        lan                   
            option dest       wifi
    
    다시 시작합니다.
    root@OpenWrt:~# reboot
    

    라우팅을 확인합니다.

    root@OpenWrt:~# route
    Kernel IP routing table
    Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
    default         192.168.3.1     0.0.0.0         UG    0      0        0 br-lan
    192.168.2.0     *               255.255.255.0   U     0      0        0 wlan0
    192.168.3.0     *               255.255.255.0   U     0      0        0 br-lan
    

    라우터 192.168.3.1에서 192.168.2.0의 경로를 설정합니다.


    속성
    수치
    네트워크 주소
    192.168.2.0
    서브넷 마스크
    255.255.255.0
    게이트웨이
    192.168.3.2
    헤아리다

    끝내다


    이상 공유기 모드로 최소한의 설정이 끝났습니다.이후 자신의 취향에 따라 조절을 즐기세요.

    좋은 웹페이지 즐겨찾기