F - Dividing 문제 해결 보고서(네트워크에서)
Time Limit:1000MS Memory Limit:10000KB 64bit IO Format:%I64d & %I64u
Submit
Status
Practice
POJ 1014
Description
Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value. Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.
Input
Each line in the input file describes one collection of marbles to be divided. The lines contain six non-negative integers n1 , . . . , n6 , where ni is the number of marbles of value i. So, the example from above would be described by the input-line "1 0 1 2 0 0". The maximum total number of marbles will be 20000.
The last line of the input file will be "0 0 0 0 0 0"; do not process this line.
Output
For each collection, output "Collection #k:", where k is the number of the test case, and then either "Can be divided."or "Can't be divided.".
Output a blank line after each test case.
Sample Input
1 0 1 2 0 0
1 0 0 0 1 1
0 0 0 0 0 0
Sample Output
Collection #1:
Can't be divided.
Collection #2:
Can be divided.
제목 대의: 돌 한 무더기를 두 개의 제목으로 나눌 수 있는지 분석: 데이터량이 좀 많기 때문에 우리의 방법은 그것을 6의 모델로 삼는 것이다.주의: 만약에 6의 배수라면 6, 만약에 0이면 0으로 설정합니다. 이것은 제가wa를 여러 번 한 이유입니다!일일이 다 들 수 있는데, 보아하니sum/2와 같습니까?다중 가방 사용 가능, 코드 예시
#include <iostream>
using namespace std;
int a[7];
int main()
{
int sum2,half,cn=0,flag;
while(1)
{
sum2=0;
for(int i=1;i<=6;i++)
{
cin >> a[i];
if(a[i]!=0&&a[i]%6==0)
a[i]=6;
else
a[i]%=6;
sum2+=a[i]*i;
}
//cout << sum2 << endl;
if(sum2==0)
break;
cout << "Collection #" << ++cn << ":
";
flag=0;
if(sum2%2==0)
{
half=sum2/2;
for(int i=0;i<=a[1];i++)
for(int j=0;j<=a[2];j++)
for(int k=0;k<=a[3];k++)
for(int x=0;x<=a[4];x++)
for(int y=0;y<=a[5];y++)
for(int z=0;z<=a[6];z++)
if(flag==0&&(i+2*j+3*k+4*x+5*y+6*z==half))
{
flag=1;
break;
}
}
if(flag)
cout << "Can be divided." << endl;
else
cout << "Can't be divided." << endl;
cout << endl;
}
return 0;
}
이 내용에 흥미가 있습니까?
현재 기사가 여러분의 문제를 해결하지 못하는 경우 AI 엔진은 머신러닝 분석(스마트 모델이 방금 만들어져 부정확한 경우가 있을 수 있음)을 통해 가장 유사한 기사를 추천합니다:
"5G"의 비즈니스 모델ICT 비즈니스는 "지금, 미국에서 일어나고 있는 일이 3~5년 후에 일본에서 일어난다""지금 중국이 가장 진행되고 있어 그것을 쫓는 일본"이라고 생각되기 쉽지만, 5G의 비즈니스는 그렇다고는 말할 수없는 상황에 있...
텍스트를 자유롭게 공유하거나 복사할 수 있습니다.하지만 이 문서의 URL은 참조 URL로 남겨 두십시오.
CC BY-SA 2.5, CC BY-SA 3.0 및 CC BY-SA 4.0에 따라 라이센스가 부여됩니다.