동적 계획 1005
A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.
The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height.
They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked.
Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.
Input
The input file will contain one or more test cases. The first line of each test case contains an integer n,
representing the number of different blocks in the following data set. The maximum value for n is 30.
Each of the next n lines contains three integers representing the values xi, yi and zi.
Input is terminated by a value of zero (0) for n.
Output
For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".
Sample Input
1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0
Sample Output
Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342
코드:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
struct node
{
int x;
int y;
int z;
}nod[105];
int dp[105];
int cmp(node a,node b)
{
if(a.x<b.x) return 1;
if(a.x==b.x&&a.y<b.y) return 1;
return 0;
}
int main()
{
int n,cas=1;
while(cin>>n&&n>0)
{
int i,j,m=0;
int a[3];
for(i=0;i<n;i++) {
cin>>a[0]>>a[1]>>a[2]; // 6 , x1<x2&&y1<y2 3 nod[m].x=max(a[0],a[1]),nod[m].y=min(a[0],a[1]),nod[m++].z=a[2];
nod[m].x=max(a[1],a[2]),nod[m].y=min(a[1],a[2]),nod[m++].z=a[0];
nod[m].x=max(a[0],a[2]),nod[m].y=min(a[0],a[2]),nod[m++].z=a[1];
}
sort(nod,nod+m,cmp);
for(i=0;i<m;i++)
{
int ma=0;
for(j=0;j<i;j++)
{
if(nod[j].x<nod[i].x&&nod[j].y<nod[i].y)
ma=max(ma,dp[j]);
}
dp[i]=ma+nod[i].z;
}
int res=0;
for(i=0;i<m;i++)
res=max(res,dp[i]);
printf("Case %d: maximum height = %d\n",cas++,res);
}
return 0;
}
이 내용에 흥미가 있습니까?
현재 기사가 여러분의 문제를 해결하지 못하는 경우 AI 엔진은 머신러닝 분석(스마트 모델이 방금 만들어져 부정확한 경우가 있을 수 있음)을 통해 가장 유사한 기사를 추천합니다:
다양한 언어의 JSONJSON은 Javascript 표기법을 사용하여 데이터 구조를 레이아웃하는 데이터 형식입니다. 그러나 Javascript가 코드에서 이러한 구조를 나타낼 수 있는 유일한 언어는 아닙니다. 저는 일반적으로 '객체'{}...
텍스트를 자유롭게 공유하거나 복사할 수 있습니다.하지만 이 문서의 URL은 참조 URL로 남겨 두십시오.
CC BY-SA 2.5, CC BY-SA 3.0 및 CC BY-SA 4.0에 따라 라이센스가 부여됩니다.