CodingTrip - 휴대용 프로 그래 밍 대회 - 세 번 째 문제 - 픽 셀 색상
3893 단어 휴대용 프로 그래 밍 대회
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 1299 Accepted Submission(s): 597
Problem Description
, (RGB R=G=B=255)。 N 。 。 , M , RGB 。
。
Input
N M, (1 ≤N, M≤ 1000 );
N 7 x1, y1, x2, y2, r, g, b, (x1,y1),(x2,y2) , RGB(r, g, b), x1≤x2, y1≤y2 ;0≤ r,g,b ≤ 255;
M X Y, 。
N=M=0 。
Output
, RGB , 3 , RGB 。
Sample Input
1 2
0 0 2 3 127 196 200
1 2
3 0
2 3
8 16 32 64 0 255 128
8 48 32 64 255 0 0
12 47
13 48
14 64
0 0
Sample Output
127 196 200
255 255 255
0 255 128
255 0 0
255 0 0
。。。。
#include<iostream>
using namespace std;
int main()
{
int m,n,i,x1, y1;int a[2001][2],b[2001][2],c[2001][3];
while(cin>>m>>n&&m!=n)
{
for(i=1;i<=m;i++)
cin>>a[i][0]>>a[i][1]>>b[i][0]>>b[i][1]>>c[i][0]>>c[i][1]>>c[i][2];
while(n--)
{ bool sort=0;cin>>x1>>y1;
for(i=m;i>0;i--)
{
if(x1>=a[i][0]&&x1<=b[i][0]&&y1>=a[i][1]&&y1<=b[i][1])
{cout<<c[i][0]<<' '<<c[i][1]<<' '<<c[i][2]<<endl;
sort=1;
break;}}
if(sort==0)
cout<<255<<' '<<255<<' '<<255<<endl;
}
}
return 0;
}