Biorhythms(poj1006)

4094 단어 Dateinputeach
Biorhythms
Time Limit: 1000MS
 
Memory Limit: 10000K
Total Submissions: 92184
 
Accepted: 28170
Description
Some people believe that there are three cycles in a person's life that start the day he or she is born. These three cycles are the physical, emotional, and intellectual cycles, and they have periods of lengths 23, 28, and 33 days, respectively. There is one peak in each period of a cycle. At the peak of a cycle, a person performs at his or her best in the corresponding field (physical, emotional or mental). For example, if it is the mental curve, thought processes will be sharper and concentration will be easier. 
Since the three cycles have different periods, the peaks of the three cycles generally occur at different times. We would like to determine when a triple peak occurs (the peaks of all three cycles occur in the same day) for any person. For each cycle, you will be given the number of days from the beginning of the current year at which one of its peaks (not necessarily the first) occurs. You will also be given a date expressed as the number of days from the beginning of the current year. You task is to determine the number of days from the given date to the next triple peak. The given date is not counted. For example, if the given date is 10 and the next triple peak occurs on day 12, the answer is 2, not 3. If a triple peak occurs on the given date, you should give the number of days to the next occurrence of a triple peak. 
Input
You will be given a number of cases. The input for each case consists of one line of four integers p, e, i, and d. The values p, e, and i are the number of days from the beginning of the current year at which the physical, emotional, and intellectual cycles peak, respectively. The value d is the given date and may be smaller than any of p, e, or i. All values are non-negative and at most 365, and you may assume that a triple peak will occur within 21252 days of the given date. The end of input is indicated by a line in which p = e = i = d = -1.
Output
For each test case, print the case number followed by a message indicating the number of days to the next triple peak, in the form: 
Case 1: the next triple peak occurs in 1234 days. 
Use the plural form ``days'' even if the answer is 1.
Sample Input
0 0 0 0
0 0 0 100
5 20 34 325
4 5 6 7
283 102 23 320
203 301 203 40
-1 -1 -1 -1

Sample Output
Case 1: the next triple peak occurs in 21252 days.
Case 2: the next triple peak occurs in 21152 days.
Case 3: the next triple peak occurs in 19575 days.
Case 4: the next triple peak occurs in 16994 days.
Case 5: the next triple peak occurs in 8910 days.
Case 6: the next triple peak occurs in 10789 days.

Source
East Central North America 1999
예를 통해 이 문제의 대의를 설명하다
세 번째 사례인 52034325를 예로 들면 p, e, i 세 개의 고봉은 각각 그해 시작 5일째, 20일, 34일째,date는 그해 시작 325일째이다.다음 삼중 고봉에서 날짜를 요구합니다. (날짜에 포함되지 않습니다.)주의
5,20,34는 반드시 그해 p,e,i가 각각 첫 번째 고봉에 나타난 시간이 아니다. 제목의 뜻에 따르면 p,e,i의 주기 길이는 각각 23,28,and33이다. 그러므로 이 예에서 세 곡선이 그해에 처음으로 고봉에 나타난 날짜는 각각 5,20과 1(34-33)이다.
사실 이것은 동여 문제다.중국의 잉여정리를 응용할 수 있다.나는 직접 폭력으로 해답을 구한다, 79ms.스카프를 쓰면 더 빠를 거예요.
AC code:
 
#include <iostream>
using namespace std;
const int lcm=21252;//23,28,33      
int main()
{
    int p,e,i,d,ans,case_i=1;
    while(cin>>p>>e>>i>>d,p!=-1)
    {
        ans=0;
        if(p>=23) p=p-(p/23)*23;
        if(e>=28) e=e-(e/28)*28;
        if(i>=33) i=i-(i/33)*33;
        for(int j=0;;j++)
        {
            ans=j*33+i;
            if(ans%23==p && ans%28==e)
                break;
        }
        if(ans<=d)
        {
            ans+=(d-ans)/lcm*lcm+lcm;

        }
        if(ans>d ) ans-=d;
        if(ans>21252) ans=21252;
        cout<<"Case "<<case_i++<<": the next triple peak occurs in "<<ans<<" days."<<endl;
    }
    return 0;
}

좋은 웹페이지 즐겨찾기