2015 바 이 두 의 별의 - IP 집합
Accepts: 138
Submissions: 293
Time Limit: 2000/1000 MS (Java/Others)
Memory Limit: 65536/65536 K (Java/Others)
Problem Description
현재 세 계 는 인터넷 이 없 는 곳 이 없다. 도 곰 은 실 수 를 저 질 렀 기 때문에 도 회사 의 네트워크 관리자 가 되 었 다. 그의 손 에는 대량의 IP 목록 이 있다. 도 곰 은 특정한 고정된 서브 넷 마스크 아래 몇 개의 네트워크 주소 가 있 는 지 알 고 싶 어 한다.네트워크 주 소 는 서브 넷 마스크 와 IP 주소 가 위치 에 따라 연산 한 결과 와 같 습 니 다. 예 를 들 어:
서브 넷 마스크: A. B. C. D
IP 주소: a. b. c. d
네트워크 주소: (A & a). (B & b). (C & c). (D & d)
Input
첫 번 째 줄 은 하나의 정수 TTT 를 포함 하고 (1 ≤ T ≤ 50) (1\\leq T\\leq 50) (1 ≤ T ≤ 50) 테스트 데 이 터 를 대표 하 는 그룹 수,
다음은 TTT 팀 테스트 데이터.각 그룹의 테스트 데 이 터 는 몇 줄 을 포함 하고,
첫 번 째 줄 두 개의 정수 N (1 ≤ N ≤ 1000, 1 ≤ M ≤ 50), MN (1\\leq N\\\leq 1000, 1\\leq M\\leq 50), MN (1 ≤ N ≤ 1000, 1 ≤ M ≤ 50), M.다음은 NNN 줄 입 니 다. 줄 마다 하나의 문자열 은 IP 주 소 를 대표 합 니 다.
다음 MMM 줄 에서 각 줄 의 문자열 은 서브 넷 마스크 를 대표 합 니 다.IP 주소 와 서브 넷 마스크 는 모두 A. B. C. DA. B. C. DA. C. D 의 형식 을 사용 하 는데 그 중에서 A, B, C, DA, B, DA, B, C, D 는 모두 마이너스 정수 이 고 255 보다 작다.
Output
각 그룹의 테스트 데이터 에 대해 두 줄 을 출력 합 니 다.
첫 번 째 줄 출력: "Case\# i:".ii 는 제 ii 조 테스트 데 이 터 를 대표 합 니 다.
두 번 째 줄 출력 테스트 데이터 의 결 과 는 각 그룹의 데이터 중의 모든 서브 넷 마스크 에 대해 이 서브 넷 마스크 아래 의 네트워크 주소 의 수량 을 출력 합 니 다.
Sample Input
2 5 2 192.168.1.0 192.168.1.101 192.168.2.5 192.168.2.7 202.14.27.235 255.255.255.0 255.255.0.0 4 2 127.127.0.1 10.134.52.0 127.0.10.1 10.134.0.2 235.235.0.0 1.57.16.0
Sample Output
Case #1: 3 2 Case #2: 3 4
이 문 제 를 풀 었 습 니 다. 테스트 를 해 보 니 문제 가 없 었 습 니 다. 그러나 지 정 된 시스템 에 제출 하 는 데 시간 이 초과 되 었 습 니 다. 전체적인 고려 에서 큰 문제 가 없 었 습 니 다. 그 다음 에 생각 했 습 니 다. 유일한 시간 은 문자열 전환 에 있 었 습 니 다. 저 는 제 가 먼저 생각 하고 깊이 생각 하지 않 은 것 이 부족 하 다 고 생각 합 니 다. 항상 입력 을 문자열 이 어야 할 것 처럼 생각 하고 그 다음 에 다른 쓰기 방법 을 제시 합 니 다.
#include <algorithm>
#include <iostream>
#include <map>
#include <vector>
#include <iterator>
#include <string.h>
#include <stdlib.h>
#include <stdio.h>
using namespace std;
vector<string> split(string s,string delim)
{
char *ss=const_cast<char *>(s.c_str());
const char *ddelim= delim.data();
char *token = strtok(ss,ddelim);
vector<string> vstr;
while(token!=NULL){
string stmp = token;
vstr.push_back(stmp);
token = strtok(NULL,ddelim);
}
return vstr;
}
string itostring(unsigned int a)
{
if(a==0)return "0";
vector<char> vc;
while(a){
unsigned int tmp = a%10;
vc.push_back(tmp+'0');
a=a/10;
}
int n=vc.size();
string s(n,'0');
for(int i=n-1;i>=0;--i)s[n-1-i]=vc[i];
return s;
}
string join(const vector<string> &vs,const string &s)
{
int n=vs.size();
string restr;
for(int i=0;i<n-1;++i)restr=restr+vs[i]+s;
restr +=vs[n-1];
return restr;
}
string ip_add(string s1,string s2)
{
vector<string> vecs1=split(s1,"."),vecs2=split(s2,".");
int n1=vecs1.size(),n2=vecs2.size();
n1=min(n1,n2);
string res;
int a1,b1,c;
for(int i=0;i<n1;++i){
a1=atoi(vecs1[i].data());
b1=atoi(vecs2[i].data());
c=a1&b1;
string stmp=itostring(c);
res=res+stmp+".";
}
res=res.substr(0,res.size()-1);
//cout<< res<<endl;
return res;
}
int main()
{
int T;
cin>>T;
for(int i=0;i<T;++i){
int n,m;
cin>>n>>m;
vector<string> vn(n),vm(m);
int r=0;
while(r<n)cin>>vn[r++];
r=0;
while(r<m)cin>>vm[r++];
vector<int> vres(m);
map<string,int> ms;
for(int k=0;k<m;++k){
for(int j=0;j<n;++j){
string tmp=ip_add(vm[k],vn[j]);
//cout<<tmp.size()<<tmp<<endl;
if(!ms.count(tmp))vres[k]++;
ms[tmp]=1;
}
}
cout<<"Case #"<<i+1<<":"<<endl;
for(int x=0;x<vres.size();++x)cout<<vres[x]<<endl;
}
return 0;
}
AC
#include <algorithm>
#include <iostream>
#include <map>
#include <vector>
#include <iterator>
#include <string.h>
#define IMIN numeric_limits<int>::min()
#define IMAX numeric_limits<int>::max()
#define FR(i,n) for(int i=0;i<n;i++)
#define CLC(x) memset(x,0,sizeof(x))
#define FILL(x,c) memset(x,c,sizeof(x))
#define viter vector<int>::const_iterator
#define vcter vector<int>::const_iterator
#include <set>
using namespace std;
typedef struct IP_ADD{
int a,b,c,d;
//IP_ADD(int _a,int _b,int _c,int _d):a(_a),b(_b),c(_c),d(_c){}
bool operator < (const IP_ADD&rhs) const
{
if(a!=rhs.a) return a<rhs.a;
else if(b!=rhs.b) return b<rhs.b;
else if(c!=rhs.c) return c<rhs.c;
else return d<rhs.d;
}
friend IP_ADD operator &(IP_ADD& rhs,IP_ADD& lhs)
{
IP_ADD x;
x.a= lhs.a&rhs.a;
x.b= lhs.b&rhs.b;
x.c= lhs.c&rhs.c;
x.d= lhs.d&rhs.d;
return x;
}
}IP;
void ip_agg()
{
int T,num=1;
cin>>T;
while(T--){
int m,n;
cin>>n>>m;
IP_ADD tn[n],tm[m];
for(int j=0;j<n;++j){
char tmp;
//cin>>tn[j].a>>tmp>>tn[j].b>>tmp>>tn[j].c>>tmp>>tn[j].d;
scanf("%d.%d.%d.%d",&tn[j].a,&tn[j].b,&tn[j].c,&tn[j].d);
}
vector<int> res(m);
cout<<"Case #"<<num++<<":"<<endl;
for(int i=0;i<m;++i){
char tmp;
//cin>>tm[i].a>>tmp>>tm[i].b>>tmp>>tm[i].c>>tmp>>tm[i].d;
scanf("%d.%d.%d.%d",&tm[i].a,&tm[i].b,&tm[i].c,&tm[i].d);
set<IP_ADD> ipset;
int count=0;
for(int k=0;k<n;++k){
IP_ADD now;
now=tm[i]&tn[k];
if(!ipset.count(now)){ count++;ipset.insert(now);}
}
cout<<count<<endl;
res[i]=count;
}
}
}
int main()
{
ip_agg();
return 0;
}
이 내용에 흥미가 있습니까?
현재 기사가 여러분의 문제를 해결하지 못하는 경우 AI 엔진은 머신러닝 분석(스마트 모델이 방금 만들어져 부정확한 경우가 있을 수 있음)을 통해 가장 유사한 기사를 추천합니다:
다양한 언어의 JSONJSON은 Javascript 표기법을 사용하여 데이터 구조를 레이아웃하는 데이터 형식입니다. 그러나 Javascript가 코드에서 이러한 구조를 나타낼 수 있는 유일한 언어는 아닙니다. 저는 일반적으로 '객체'{}...
텍스트를 자유롭게 공유하거나 복사할 수 있습니다.하지만 이 문서의 URL은 참조 URL로 남겨 두십시오.
CC BY-SA 2.5, CC BY-SA 3.0 및 CC BY-SA 4.0에 따라 라이센스가 부여됩니다.