1731 Orders POJ
Orders
Time Limit: 1000MS
Memory Limit: 10000K
Total Submissions: 5599
Accepted: 3589
Description
The stores manager has sorted all kinds of goods in an alphabetical order of their labels. All the kinds having labels starting with the same letter are stored in the same warehouse (i.e. in the same building) labelled with this letter. During the day the stores manager receives and books the orders of goods which are to be delivered from the store. Each order requires only one kind of goods. The stores manager processes the requests in the order of their booking.
You know in advance all the orders which will have to be processed by the stores manager today, but you do not know their booking order. Compute all possible ways of the visits of warehouses for the stores manager to settle all the demands piece after piece during the day.
Input
Input contains a single line with all labels of the requested goods (in random order). Each kind of goods is represented by the starting letter of its label. Only small letters of the English alphabet are used. The number of orders doesn't exceed 200.
Output
Output will contain all possible orderings in which the stores manager may visit his warehouses. Every warehouse is represented by a single small letter of the English alphabet -- the starting letter of the label of the goods. Each ordering of warehouses is written in the output file only once on a separate line and all the lines containing orderings have to be sorted in an alphabetical order (see the example). No output will exceed 2 megabytes.
Sample Input
bbjd
Sample Output
bbdj
bbjd
bdbj
bdjb
bjbd
bjdb
dbbj
dbjb
djbb
jbbd
jbdb
jdbb
Source
CEOI 1999
STL 방법...
int n=strlen(str);
sort(str,str+n);
printf("%s/n",str);
while(next_permutation(str,str+n))
printf("%s/n",str);
회소법
#include<iostream>
using namespace std;
char s[205];
char res[205];
bool b[205];
int N;
int cmp(const void * a,const void * b)
{
return *(char * )a-*(char *)b;
}
void backtrace(int n)
{
if(n==N)
{
printf("%s/n",res);
return ;
}
int i;
for(i=0;i<N;++i)
{
if(b[i]==false)
{
res[n]=s[i];
b[i]=true;
backtrace(n+1);
b[i]=false;
while(i<(N-1) && s[i]==s[i+1])//
i++;
}
}
}
int main()
{
scanf("%s",&s);
N=strlen(s);
res[N]='/0';
qsort(s,N,sizeof(char),cmp);
memset(b,0,sizeof(b));
backtrace(0);
return 0;
}
이 내용에 흥미가 있습니까?
현재 기사가 여러분의 문제를 해결하지 못하는 경우 AI 엔진은 머신러닝 분석(스마트 모델이 방금 만들어져 부정확한 경우가 있을 수 있음)을 통해 가장 유사한 기사를 추천합니다:
Lua 리 디자인 줄거리 체인result: >lua -e "io.stdout:setvbuf 'no'""Main.lua" ---------- initScene ---------- on EVENTS: 1313262659 | Map: 7 on ...
텍스트를 자유롭게 공유하거나 복사할 수 있습니다.하지만 이 문서의 URL은 참조 URL로 남겨 두십시오.
CC BY-SA 2.5, CC BY-SA 3.0 및 CC BY-SA 4.0에 따라 라이센스가 부여됩니다.