joj 1195
1195: Prime Ring Problem
Result
TIME Limit
MEMORY Limit
Run Times
AC Times
JUDGE
10s
8192K
1973
499
Standard
A ring is composed of n circles as shown in diagram. Put natural numbers into each circle separately, and the sum of numbers in two adjacent circles should be a prime.
Note: the number of first circle should always be 1.
Input
n (0 < n <= 16)
Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements.
You are to write a program that completes above process.
Sample Input
6
8
Sample Output
Case 1:
1 4 3 2 5 6
1 6 5 2 3 4
Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2
#include <iostream>
#include <cmath>
using namespace std;
const int maxn = 33;
int isp[maxn], n, a[10000],vis[10000];
bool judge(int x)
{
int i;
for (i=2; i<=sqrt((double)x); i++)
{
if (x % i == 0) return false;
}
return true;
}
void makeprime()
{
int i;
for (i=2; i<=maxn; i++)
if (judge(i)) isp[i] = 1;
}
void dfs(int cur)
{
if (cur == n && isp[a[0]+a[n-1]]==1)
{
int i;
cout<<a[0];
for (i=1;i<n; i++)
{
cout<<" "<<a[i];
}
cout<<endl;
}
else
{
int i;
for (i=2; i<=n; i++)
{
if (!vis[i] && isp[i+a[cur-1]] == 1)
{
a[cur] = i;
vis[i] = 1;
dfs(cur+1);
vis[i] = 0;
}
}
}
}
int main()
{
makeprime();
int count=0;
while (cin>>n)
{
count++;
cout<<"Case "<<count<<":"<<endl;
if(n%2==0)
{
memset (a,0,sizeof(a));
memset (vis,0,sizeof(vis));
vis[1] = 1;
a[0] = 1;
dfs(1);
}
cout<<endl;
}
return 0;
}
이 내용에 흥미가 있습니까?
현재 기사가 여러분의 문제를 해결하지 못하는 경우 AI 엔진은 머신러닝 분석(스마트 모델이 방금 만들어져 부정확한 경우가 있을 수 있음)을 통해 가장 유사한 기사를 추천합니다:
application ---- enter and save the file codeInput file name and content - input_content.html Receive content and save file and content - input_content01.jsp...
텍스트를 자유롭게 공유하거나 복사할 수 있습니다.하지만 이 문서의 URL은 참조 URL로 남겨 두십시오.
CC BY-SA 2.5, CC BY-SA 3.0 및 CC BY-SA 4.0에 따라 라이센스가 부여됩니다.