1066: Fire Net II

1066: Fire Net II
Status
In/Out
TIME Limit
MEMORY Limit
Submit Times
Solved Users
JUDGE TYPE
stdin/stdout
3s
8192K
403
172
Standard
1st JOJ Cup Online VContest Warmup Problem
Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall.
A blockhouse is a small castle that has eight openings through which to shoot. The eight openings are facing North, Northeast, East, Southeast, South, Southwest, West and Northwest, respectively. There will be one machine gun shooting through each opening.
Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets.
The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row, vertical column and diagonal line in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 8x8) that contain walls through which bullets cannot run through.
The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 4; the second picture shows one way to do it, but there are several other ways.
 
Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration.

Input Specification


The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 8. The next n lines each describe one row of the map, with a '.' indicating an open space and an uppercase 'X' indicating a wall. There are no spaces in the input file.

Output Specification


For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.

Sample Input

4
.X..
...X
XXX.
..X.
2
XX
.X
3
.X.
X.X
.X.
3
...
.XX
.XX
8
........
........
........
........
........
........
........
........
0

Sample Output

4
1
2
2
8
#include<iostream>
char map[10][10];
int sum,n;
bool ok(int x,int y)
{
	int i,j;
	for(i=x-1;i>=0;i--)//  map[x][i]!='X' , I>=0
	{ 
	  if(map[i][y]=='*') return false;
	  if(map[i][y]=='X') break;
    }
	for(i=y-1;i>=0;i--)
	{
	  if(map[x][i]=='*') return false;
	  if(map[x][i]=='X') break;
	}
	for(i=x-1,j=y-1;i>=0,j>=0;i--,j--)
	{
	  if(map[i][j]=='*') return false;
	  if(map[i][j]=='X') break;
	}
	for(i=x-1,j=y+1;i>=0,j<n;i--,j++)
	{
	  if(map[i][j]=='*') return false;
	  if(map[i][j]=='X') break;
	}
	return true;
}
void dfs(int k,int nowsum)
{
	int x,y;
	if(k>=n*n)
	{
		if(nowsum>sum) sum=nowsum;
		return;
	}
	else
	{
		x=k/n;
		y=k%n;
		if(map[x][y]=='.' && ok(x,y))
		{
			map[x][y]='*';
			dfs(k+1,nowsum+1);
			map[x][y]='.';
		}
		dfs(k+1,nowsum);
	}
}
int main()
{
	int i,j;
	//freopen("in.txt","r",stdin);
	//freopen("out.txt","w",stdout);
	while((scanf("%d",&n),n)!=0)
	{
		for(i=0;i<n;i++)
		   scanf("%s",map[i]);
		sum=0;
		dfs(0,0);
		printf("%d/n",sum);
    }
	return 0;
}

좋은 웹페이지 즐겨찾기