1003: Channel Allocation 착색 문제 4색 정리
Result
TIME Limit
MEMORY Limit
Run Times
AC Times
JUDGE
3s
8192K
3211
561
Standard
When a radio station is broadcasting over a very large area, repeaters are used to retransmit the signal so that every receiver has a strong signal. However, the channels used by each repeater must be carefully chosen so that nearby repeaters do not interfere with one another. This condition is satisfied if adjacent repeaters use different channels. Since the radio frequency spectrum is a precious resource, the number of channels required by a given network of repeaters should be minimised. You have to write a program that reads in a description of a repeater network and determines the minimum number of channels required.
INPUT
The input consists of a number of maps of repeater networks. Each map begins with a line containing the number of repeaters. This is between 1 and 26, and the repeaters are referred to by consecutive upper-case letters of the alphabet starting with A. For example, ten repeaters would have the names A,B,C,...,I and J. A network with zero repeaters indicates the end of input. Following the number of repeaters is a list of adjacency relationships. Each line has the form: A:BCDH which indicates that the repeaters B, C, D and H are adjacent to the repeater A. The first line describes those adjacent to repeater A, the second those adjacent to B, and so on for all of the repeaters. If a repeater is not adjacent to any other, its line has the form A: The repeaters are listed in alphabetical order. Note that the adjacency is a symmetric relationship; if A is adjacent to B, then B is necessarily adjacent to A. Also, since the repeaters lie in a plane, the graph formed by connecting adjacent repeaters does not have any line segments that cross.
OUTPUT
For each map (except the final one with no repeaters), print a line containing the minumum number of channels needed so that no adjacent channels interfere. The sample output shows the format of this line. Take care that channels is in the singular form when only one channel is required.
SAMPLE INPUT
2
A:
B:
4
A:BC
B:ACD
C:ABD
D:BC
4
A:BCD
B:ACD
C:ABD
D:ABC
0
SAMPLE OUTPUT
1 channel needed.
3 channels needed.
4 channels needed.
#include<iostream>
#include<cstdio>
#include<string>
#include<cstring>
using namespace std;
int n;//
int a[30][30];//
int x[30];//
int m;//
int flag;
int check(int id)
{
for(int i=1;i<id;i++)
{
if(a[id][i]&&(x[id]==x[i])) return 0;// ,
}
return 1;
}
void dfs(int id)
{
if(id==n+1)
{
flag=1;
return ;
}
for(int i=1;i<=m;i++)//
{
x[id]=i;
if(check(id)) dfs(id+1);
}
}
int main()
{
while(cin>>n&&n)
{
memset(a,0,sizeof(a));
for(int i=1;i<=n;i++)
{
string str;cin>>str;
for(int j=2;j<str.size();j++)
{
a[str[0]-'A'+1][str[j]-'A'+1]=a[str[j]-'A'+1][str[0]-'A'+1]=1;
}
}
flag=0;
for(m=1;m<=3;m++)//4
{
memset(x,0,sizeof(x));
dfs(1);
if(flag) break;
}
if(m==1) printf("1 channel needed./n");
else printf("%d channels needed./n",m);
}
return 0;
}
이 내용에 흥미가 있습니까?
현재 기사가 여러분의 문제를 해결하지 못하는 경우 AI 엔진은 머신러닝 분석(스마트 모델이 방금 만들어져 부정확한 경우가 있을 수 있음)을 통해 가장 유사한 기사를 추천합니다:
application ---- enter and save the file codeInput file name and content - input_content.html Receive content and save file and content - input_content01.jsp...
텍스트를 자유롭게 공유하거나 복사할 수 있습니다.하지만 이 문서의 URL은 참조 URL로 남겨 두십시오.
CC BY-SA 2.5, CC BY-SA 3.0 및 CC BY-SA 4.0에 따라 라이센스가 부여됩니다.